Think I found a correction -

Trying to follow the Django course. I am in Django fundamental #6 at 1:25.

When I run a terminal in VS, it doesn’t seem to have the pipenv set up. If I run ‘pipenv shell’ in each terminal then it seems to work.

In setting the path for the python interpreter, the …\bin\python path doesn’t seem to exist for windows 10! I think it should be …\Scripts\python.exe directory. Things seem to work with that change.

Is this correct?


Hey Jeff, Thank you for pointing it out.

You are absolutely correct, the instructions in the video are for Mac OS and UNIX (Linux) not for Windows.

Mosh said to use back slashes for Windows instead of forward but he failed to catch the different path.

Why ? … it should be easy to run through a separate Windows 10 setup in the instruction aswell.

When I bought the course I was not made aware I purchased a MAC/Linux dominated course !!

I noticed from the Q&A sections that others have the similar Windows 10 guidance issues.

I am having some addition errors when trying to follow the course with Win 10. Could be my error but … I hope Mosh will at least add text overlays to his videos when he finds Win 10 unique requirements so we won’t have to search for others who have figured it out! Mosh?

Jeff … fully supported.

I have temporarily put this course on hold !

I’m taking a couple of courses in parallel (IoT, Python - YouTube, Python Mosh).

Some people say it’s an additional learning experience to sort issues out, but sorting basic issues out (e.g Windows 10 setup issues) is time consuming and not productive in my opinion.


I took his Python course a while back and was very happy with it. He is an excellent teacher. But I do hope when corrections are needed to his content that he will make them at least as an overlay. Practice is one thing for addition learning but correcting a mistake in the content is quite different and will not serve him well if it is frequent.

:+1: Fully agree … I wait and see.

For my django- admin issue a fellow student has asked for a "snip’ … see if we can find a solution.

try change /bin/python to Scripts\python