Settings json error inside Visual Studio code

hi, can someone help me with this? I actually tried to change python_u into python3 but the Video in the course is not up to date so these … on the right of the settings inside of Visual studio code is not there anymore so i tried to find these settings and like in the picture i just did something wrong and now i always see these errors and dont know if i damage something on Python or how can i fix it ?

1 Like

Hi,
On line 6 after the brace you need to put a comma and on line 58 you either have to put a missing brace or comma.

HOW did you get to the .json file? I cant find it at all… like you, i didnt have the "3 dots"on the right that said open setting.json… Now, when i search in the setting I find JSON underextensions… but when I click the link for edit setting, the file only has 2 lines of code in it… how do you find this huge file with the executorMap in it?

2 Likes

in the given searchbar, type code-runner executor below, you’ll be given various settings related to json. look for the one with coderunner executor map, click

1 Like

i found a solution but I must’ve posted in a different thread… typing code-runner into search yielded nothing for me. Also, there must be multiple variables re: what each person will experience on their setup. OSX version, vscode version, code-runner version, etc. What I did to make it work, was to uninstall code-runner… the moment you do that, an option becomes available to install older versions… I chose a version from 2018 (since that’s when Mosh made this)… once I did, “code-runner” in the search bar yielded an “Edit json” link, and BOOM!!.. I was in business!!

I thank you for your reply!!.. much love :slight_smile:

1 Like

Just got to this section, and using the search bar in the settings window worked for me, thanks for this Minnie!

In the giving search bar in settings right?

make sure you type code-runner with a dash and not code_runner

Hello, I have same problem too. Do you have the solution?

Using Python 3.10.1 on Mac

Clicking the three dots, there is no ‘open settings.json’

There three other options I found using search, but the results are different than what is in the video (I can only upload one screen shot unforunately)

A quick google search for ‘code runner mac’ didn’t yield helpful results immediately

Anyone using the version 3.10.1 have a solution?

Works now. Not sure what changed from before.

what works because I’m having this same issue

Same here too. On my VSC version where the 3 dots should be is a blue button that says Turn on Setting Sync…

Hi Julie, could you pls help me, I also cannot finds those json.settings

Hi Kushminer, could you pls help how you fixed this? I have the same options available now only

New to this site. I’m having the same problem. This program is not living up to ‘Python made easy’. The fact that a true solution has not been posted here is concerning. To me this indicates at least this course isn’t being kept up to date.

This is what I see when I type in code-runner.executorMap and click on the selection:

“python.defaultInterpreterPath”: “/Applications/anaconda3/bin/python”,
“terminal.integrated.inheritEnv”: false,
“editor.formatOnSave”: true

That’s it. I have no idea where the “python” : “python -u” is located that is shown in the video.