Python beginner course

How do i add “code-runner.executermap”

Cant seem to find the settings like in image attached

I’m Stuck exactly in that video. I can’t find a way to change the python-u setting to Python3 as Mosh suggests we do in his course.

I think I got this to work. After you click on Code > Preferences > Settings, enter “code-runner.executorMap” in the Search window. Click on the edit-settings.json under the first option. Add a comma at the end of the last line showing and type “code-runner.executorMap”: on the next line. Then all of the various choices showed up. Change the “python -u” to “python3” and save your changes.


Yes thats what i did as well and it worked!

Hey guys I’m having issues using VScode on my operating device, although from Mosh’s previous tutorial on YouTube I have pycharm and at the moment seem more comfortable using that. Is it still fine to use pycharm for this course?

PyCharm is perfect. Only thing is that you will have to figure out PyCharms version of the shortcut keys that Mosh uses in VS Code but that is not really that important.

Cheers mate, I’ve been a lot of issues with VScode but this clears up everything

1 Like

I only use PyCharm. :wink:

In lesson 2 of the python package index the app’s first line is:

import requests

but this results in an error: Module not found.

What to do?

I ran python -m pip show requests

and it returned that I have version 2.26.0.

SO, why can’t I import requests?

And when I run pip3 list I get:

Package Version

certifi 2021.10.8
charset-normalizer 2.0.8
idna 3.3
pip 21.3.1
requests 2.26.0
setuptools 57.4.0
urllib3 1.26.7
wheel 0.37.0

BUT I think something else is amiss. In the lesson, after running env -m venv env, there is no bin folder created.


One reason that this may happen is that you are running python in a virtual environment but that the packages are installed elsewhere. Make sure you switch to your virtual environment. Not sure if you are on Windows or Mac? On windows from within your project directory do the following (assuming your virtual environment is in .env.) run the following command:


then check again if your packages are installed.

I’m using Visual Studio Code on Win10. The code which didn’t work properly (import responses) was in the Terminal. I’m not running a virtual environment. Should I?