Problem with Running Python Code

Hi!

I am a complete beginner to Python. I have just purchased Mosh’s Python course yesterday, and I am having a little bit of trouble with setting VSCharm up.

I am currently on a Mac. The video tells me that by default, the command is using python -u, which means that it is Python 2 and not Python 3. It tells me to go to settings, click the 3 dots on the top right corner, and click “open settings.json”. Then, it tells me to type “code-runner.executorMap” in the search bar above.

Finally, it tells me to change the user settings on the right side under the last line of code. It tells me to type “code-runner.executorMap”, press enter. This is supposed to copy the settings from the left to the right, where I can finally edit “python -u” and change it into “python3”.

However, on my computer, it doesn’t show the 3 dots. Instead of the 3 dots, it just says “Last synced [] hours ago”.

Please see pictures below on how my screen looks vs how the screen in the video looks.
(Just noticed that new users can only put one picture in a post for some reason. See the replies in this post for how the screen looks in the video)

My screen:

Screen in the video:
(see replies in this thread)

Does anyone have a solution on how I can solve this problem and change it to python3? Any help would be appreciated.

Thanks!

Here is how the screen looks in the video:

Hi @LegendLife1 If you check next to your run code button you will find the button open settings.json

@lyndonmenezes Thanks a lot!! The problem is fixed now.

@LegendLife1 No problem ! Thats awesome ! I am a beginner too and I faced the exact same problem. What I learnt so far is that you need to just spend some more time finding things out.

1 Like