Help with code-runner.executormap

Help with code-runner.executormap!!!

I just started the course and I was following along the vscode set up until I got to the point where the professor copy the code-runner to the user settings the things is that I can’t find the use setting I’ve found the J.SON settings but I can’t seem to find the the other tab where he changed the python 2 to python3 (perhaps I’m using a different version of vscode)

Thank you.

I think you should install the python extension. and did you install the code runner? I had the same issue when i install the code runner, the problem solved.

Hi there, I am stuck with the same problem. I cannot edit settings.json file, it gives me an error “cannot edit in read-only editor”. Can someone help me with this?

There are two places you need to set Python3 as the interpreter:

In Mac: Code → Preferences → Extensions → Python → " Default Interpreter Path"

Then in your settings.json file, unless you need to change all of the languages from their default you only have to add the ones you are changing. Just add the following after the last attribute and the before the closing curly bracket.

"code-runner.executorMap": {
    "python": "$pythonPath -u $fullFileName",

What that is saying is the python version used will be the same one as you set up above in your VSCode settings.