Java course issues

So I started the video course today and found that the instructions to use “JDK version 12” are no longer valid. Also a lot of the code that is used in some of the early lessons throws errors.

Since I paid for these courses, I would like them to be updated.

I would be surprised because I’m pretty sure the core library code Mosh was writing has been stable. What code is throwing errors?