Git bisect works differently

I’m referring to the lesson “Finding bugs using bisect”
Every time I try to use a bisect command I get an error that prevent me to execute it. I always have to stage changes and then commit. But this way history become different from the one of the lesson and at the end the situation is completely different.
If someone has the same issue please tell me

I had the same sort of error with the lesson on checkout and my workaround was to add the option -f to force the checkout

For Windows users: I solved the issue:
when I import the repository Venus, git detects working area dirty
But now I know why!
If you run
git diff HEAD
you get for all files this output:
old mode 100644
new mode 100755
This is due to unix permission modes
755 =rwxr-xr-x
644 =rw-r--r--

So, to solve the issue, before starting to use the repository set this configuration
git config core.filemode false
Now working directory is clean

I hope this can be useful to someone else.

1 Like

Thanks for posting what you found. It really saved me a lot of time.

I’m glad to hear that :slight_smile: