VS Code Ouptu Panel

How do I stop the [Running] and [Done] tags from showing in the output panel. They are distracting?

Thanks.

Hi there.
I have the same problem.
I know that this question might be funny to someone, but I am too just a beginner and I carefully follow all videos and every step in them. This is skipped to be explained and I lost hours to find out how to hide it with no success.
In one lesson you see these rows in output and in very next they are gone without explanation.

Hope we will get some instructions here.

Thanks

Hi Ivan. These 2 videos helped me. It’s not exactly the same as the versions are different but they helped me.

https://youtu.be/9hngN931cJY

https://youtu.be/NSZqn1VrzVc

Hopefully it will help you. Basically this guy runs it from the debug but without debugging. It helped me. Hopefully it can help you too. I recommend watching both before trying anything.

Hey Kevin

Thanks for the reply man.
I tried this and it remained the same in output, maybe because I’m using Windows…
Do you still have [Running] and [Done] in Output window?

Thnx

I do but if I change from Terminal or Output to Debug Console I get only the output. As long as I click Run>Run Without Debugging. You can also just push F5.

Again be sure to make sure to make sure you are looking in the Debug Console, not the Terminal or Output window. Sometimes it automatically changes it to the correct window but sometimes I have to manually change the output view.

You’re right, it changes automatically to Output when I do the run and I see in video lessons that Mosh is in Output window always.

Anyhow, I also started watching tutorial on YouTube, for which I thought it would be the same, but I find it much better and instead of Visual Studio Mosh uses PyCharm in YouTube version, which I also like more.
I just wish I could be able to work in both tools and understand them both…

Ivan,
I do like the YouTube videos alot too. I also like PyCharm better as well. I have watched so many different tutorials which each require a different IDE that I’ve got myself very confused. LOL. So, I’ve decided to just stick with VS Code and Mosh.

LOL, I agree with that 100% :))
I watch few tutorials at the same time so to get more information from different sources but even two Python courses from Mosh look like two different stories :))

Thnx Kevin

Hi both was looking for the solution myself, finally figured.
Under the user setting look for the following and change it to False. Hope it Helps…

// Whether to show extra execution message like [Running] … and [Done] …
“code-runner.showExecutionMessage”: true,