Settings.json missing

When Mosh asks to modify the Python interpreter to the one of the virtual environment, .vscode folder with settings.json inside is not created. This is because there is in course at the development team an experiment for removing ` the python.pythonPath.

Reading a useful post about the issue under github I found this:
“To opt out of the experiment, you can set “python.experiments.optOutFrom” to either the specific experiment or to ["All"] to opt out of all experiments.”

I made this modification in the user settings and it works.
Now the info about the interpreter path are stored in the .vscode/settings.json file under my project folder.

2 Likes

How do you generate the settings.json file after you have updated the user settings? I’ve tried changing the interpreter and then changing it back to the one in my virtual environment, but no files are generated.

Still .vscode folder not created after updating user settings.