Part 1: Getting Started: 13 Debugging in VSCode NOT working


My OS: Windows 10 Pro

inserted a break point in code at:
→ let x = 1;
In debug panel:
Choose “Attach to packager” and click green run button
OUTPUT window:
[Info] Packager started.
-----NOTE: I ran netstat and cannot determine what port Packager is running on

Attaching to the application
Starting debugger app worker.
Established a connection with the Proxy (Packager) to the React Native application

Mosh reloads AVD (so it must of been started prior)
So I stop debugger, run app → $npm start, then connect to AVD
On AVD I go to Dev Mode, and reload
looks like code stopped at breakpoint, BUT the debugger only allows Restart and Stop

Mosh’s debugger allows All Operations and the breakpoint is highlighted
…my npm start is still running (with the React Native Debugger tab open), so I close the tab and reload from AVD which launches a React Native Debugger tab again. In debug panel: I stop the debugger. In the Console Window cntrl-C (stop native-react app)
I notice that the AVD getting a network communication error (As I would expect!)
I start the debugger
From AVD, I do a reload (see spinner), then get:
“Something went wrong.
Network response timed out”

Looks like I have “a chicken before the egg” problem here.

Hi JerryC

I too have same experience with you.

even using “react native debugger” not working on my machine

I guess because it’s operating system “windows” or the android emulator expo

Just FYI.- newest OS/Devices might not be fully supported. In my case I tried iOS 14.5 with simulator and it totally crashed expo ton of errors.

I wasn’t able to fix it with the newest iOS, so I went back a couple of iOS versions and it now all works flawless. Have you guys tried a similar approach in Android?

React Native Debugger is not working. Apparently there is a problem with React Native. See this link: