How do I solve this

I solved it this way @Valour , hope will help you too:

  1. In the project directory:
    a) Created a file called “.htmlnanorc.js” with content:
    module.exports = {
    minifySvg: false,
    b) Created another file called “.htmlnanorc” with a single line:
    { “minifySvg”: false }
  2. In the Terminal I run the “parcel build index.html” adding “–no-minify” as a parameter:
    “parcel build index.html --no-minify”
  3. In the configuration parameters of Netlify for the deploy, I also write the same command to be executed when building my deploy:
    “parcel build index.html --no-minify”

All problems are gone and now anytime I push to GitHub, Netlify publish my updated site as expected

Hope this will help you


I think I found the SVG file that was going wonky and I just uploaded the SVG to images and linked that individual icon instead of the SVG bundle left the rest, might have had to delete the code. Good luck