External alternative to react native backend server

hello guys… So its been a “difficult” few days trying to get the back end to work with my app. I unzipped the backend folder in the root of my project. run npm install and created the necessary files in api folder in the “end folder”.

i have followed all the tips suggested in this forum and also some from stack overflow and github.
Apart from addition solutions, i want to know if there is an external service that can take care of the server issue when i concentrate on learning reactive native.

I share your frustration of being “stuck” on a problem for hours (or days) – I’ve been there.

The backend server works, and getting it working is better than trying to connect to another external server. You might try these steps.

The error message indicates the app project is not finding the apisauce library. It should be listed in the “dependencies” section of the package.json file. If you don’t see it there, you need to install it via expo add apisauce (or yarn add apisauce – Expo uses yarn under the hood).

Also, for the app and server to work properly together, you need to be sure the http address is set correctly in the code for each. In the “donewithit” app, the setting is in the settings.js file in the config folder. You need to have the correct address for the URL http://192.168..
Screen Shot 2021-05-03 at 6.08.13 PM
This is the address (URL) of your computer on your local network.

Similarly, there’s a setting for the backend. It is in the development.json file in the config folder.
Screen Shot 2021-05-03 at 6.12.14 PM

I hope this helps!

And, to be clear, on a Windows machine, here are instructions on how to find the specific IP address of your machine: Find your IP address

On a Mac, you go to System Preferences, then Network – the window will show the IP address.

If it’s running locally on your computer you can use localhost instead op the IP address.

http://localhost:9000/

Excellent tip, William! I tried this and it worked. Much easier than having to input the specific IP address – particularly since that can change if you reboot your local wireless router (if you use one).

To be clear, I’m using this setup on the backend:
Screen Shot 2021-05-06 at 8.29.31 AM

And this on the frontend:
Screen Shot 2021-05-06 at 8.30.50 AM

Great tip – thanks!