Error opening ODBC Administrator in MySQL Workbench

I ran into a problem trying to migrate Microsoft Access database to mySQL.
I’m getting an error message: “ODBC Administrator utility could not be found”, as on the attached screenshot.
I tried it on both Windows 10 & 11.


Did you read the official docs?

There is a section about ODBC drivers.


Yes I did. I doesn’t address the error issue. If I ignore it and proceed to the next step of the wizard, it doesn’t show any items in the “Stored Connection” combo box. It makes it impossible to continue with the wizard. I am assuming it’s related to the error on the previous step/screen.

From further reading I’m assuming that the Windows ODBC administrator is what MySQL ultimately intended to open, and the error is a benign glitch. However, it still leaves the issue unresolved, as I cannot see my MS Access pre-configured ODBC data source on the following screen of MySQL Workbench (see attached screenshot)

I’m starting to suspect this is due to a mismatch between system architectures. My Access database is 32-bit and I am running 64-bit MySQL on a 64-bit computer.
Can anyone help me with this?

I resolved this issue by downloading MS Access Database Engine 2010 Redistributable here:,
and installing it on the computer where MySQL Workbench is installed. It allowed me to select Microsoft Access Driver from the list of DSN’s (see the screenshot)

1 Like