./docker-entrypoint.sh: Permission denied vidly-backend-1 exited with code 126

I am getting error while executing docker-compose up command.

Vidly-backend-1 | /usr/local/bin/docker-entrypoint.sh: exec: line 8: ./docker-entrypoint.sh: Permission denied vidly-backend-1 exited with code 126

I added the permission: chmod og+x docker-entrypoint.sh, but still getting ‘permission denied’ error. Also, tried root user in place of app for backend project but still same issue.

Frontend and Db are up and running perfectly, only backend causing issue.

Any help/suggestion will be appreciated.


Why did you add x on go and not on u ?


Because it already has x on u but not for go.

I guess, problem is something else, which I could not resolve yet.

-rwxr-xr-x@ 1 dev-user staff 160 24 Sep 14:20 docker-entrypoint.sh

It has execute (x) permission for all but still getting permission denied error while executing ‘docker-compose up’ command.

I resolved the issue, added xwr permissions and it worked.

Some other files was also causing permission issue which are resolved by adding necessary permissions.

Hi Irfan, please how did you do this? Currently going through the same problem.