4- The Sample Web Application

Hey, when I try to run docker-compose up, I get a permission denied on the docker-entrypoint.sh. I already tried to modify the backend docker script to give the app user x permission for that file, but it seems to not solve it.

Creating vidly_db_1 … done
Creating vidly_backend_1 … done
Creating vidly_frontend_1 … done
Attaching to vidly_db_1, vidly_backend_1, vidly_frontend_1
backend_1 | /usr/local/bin/docker-entrypoint.sh: exec: line 8: ./docker-entrypoint.sh: Permission denied

It runs the application, but I don’t get Database access.

Can somebody help?

1 Like

If somebody got the same issue: I solved it after some struggling.

Go to the Backend docker file and add these lines after COPY . .

My Dockerfile looks like this now:

Thank you so much for sharing this information with us;
I got the same issue with the web application but after watching your information
I get my solution… thank you so much…

Screenshot from 2021-11-29 13-58-23

This is what worked for me! :slight_smile:
I also had to clean my workspace to start fresh.

clear all containers- (sudo) docker container rm -f $(docker container ls -aq)
clear all images- (sudo) docker image rm -f $(docker image ls -q)

then run…

docker-compose up

hope this helps!