Can't inizialitize git hub repository on VsCode

Hi!! Well I’ve been trying for a long time to initialize a repository on VsCode (i’m following HTML5 & CSS 3 course). Every time i try press “initialize repository” button it does nothing, i can’t “press it” (it’s like is enabled), it just doesn’t seem to work … Already created a Git Hub acc, installed Git Hub for desktop, went to “git hub” extension on VS to try to initilize it… but it doesn’t work

I have no idea what to do.
Grateful to hear your tips


There is a distinction between GitHub and Git. GitHub is an over-the-network centralized Git repository. Git is for local repository management. You may need to install Git itself if you have not already.

1 Like

My bad, i meant to say i already installed “Git”! Thank you so much for the clarification
Hope there’s something else we can do so i can “fix” my problem

thank you

A few more ideas:

  1. Have you checked the docs linked to by the extension? They might have some more explicit setup instructions for making the extension work properly on Windows.
  2. Have you tried the classic “turning it off and turning it back on again”? Some ways to do this include: (a) closing and reopening VSCode, (b) restarting your computer, (c) uninstall and reinstall the extension, (d) uninstall and reinstall Git.

Let me know if any of those help you make progress.

1 Like

Thank you so much!! I’ll try all of them and let you know the feedback, thanks for your help. I’m sure somehow it’ll work

1 Like

I tried restarting and updating my computer AND IT WORKED!!! THANK YOU SO MUCH
You don’t know how grateful i am hahaha, i’ve been desperately looking, pressing, and just typing weird stuff to make it work and not even once thought of simply “restarting” my computer. Thank you, have a nice day

1 Like