React native version mismatch

Hey guys, so I’m trying to use the demo that comes with the course, but when I tried running it on the simulator it told me SDK version was too old, so I updated the SDK and now it is telling me the react native version does not match like this:

The real problem is the app that Im making following the course have the same problem now, I saw a solution telling me to shut down all terminals and restart, here: React Native version mismatch - Stack Overflow, so I shut down VS code, metro bundler on browser and the emulator to start again, didn’t work, did I do something wrong? Are there more than those three terminals to close or something else?
Please help, thank you

My react native version is 0.64.2, but it is still telling me that it is 0.61.4

At the command prompt in your project folder, run: expo diagnostics

That will give you a summary of all the elements of your expo environment. You can use that information (and some online searching) to figure out if you have version conflicts between Expo SDK, react-native libraries, node, etc.

I used

Expo Update

at terminal to bring all environment elements up to date. I run fine with this setup. There are occasional syntax conflicts that you can fix yourself but nothing major. Here is the result of my environment diagnostics for your reference:

Expo CLI 4.10.0 environment info:
OS: Windows 10 10.0.19042
Node: 14.17.4 - C:\Program Files\nodejs\node.EXE
npm: 6.14.14 - C:\Program Files\nodejs\npm.CMD
expo: ^42.0.0 => 42.0.3
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
Expo Workflow: managed

1 Like