Primitive Types

I have watched this short clip, however when Mr Mosh enters the code attatched, why is there a scratch?

He has not saved yet, so I am not sure what is in the saved file in that screenshot. It is most likely just the linter lagging behind the input. If you type the same into your VSCode and then save the file, do you still get a strike through?

OK, I just tried typing the same into my own instance of VSCode and it looks like it thinks that the name variable is a deprecated keyword of some kind (coming from the typescript). If you hover over it, you can see what the error message says:

‘name’ is deprecated.ts(6385)

Then it has a pointer to a specific file defining some types and marking name as deprecated. Looking this up elsewhere led to this: https://www.reddit.com/r/vscode/comments/ltonp7/name_is_deprecated_ts6385/

I think basically this is just a nuisance caused by typescript linting and can be ignored. Alternatively you can follow the advice in that Reddit post.

2 Likes

Yes, unfortunately I am getting the following error:

Couldn’t I by pass and assign a variable as (let important_name).

I wouldn’t think it would make a difference. After all it is only assigning “important_name as a variable”.

Yep, but if you needed to use name in the global namespace, you can probably just ignore the warning.

2 Likes