Issue in Creating Directory

Hey all,
I’ve begun the Git course and after having set the configuration, I see in the video Mosh has already indicated the Path and you see the path in Bash Command, but I can’t set my path for new directory etc… I got the error “No command found”

Has someone faced the same issue?
How can I fix it ?

Thank you in advance


can you share any output from mosh video along with yours ?
I believe you may not understand how to input those commands (if you used git for windows).

Mosh often uses Mac which AFAIK is close to Linux
So you may have a directory such as /home/username/repos/gitdemo/
On Windows you must start by including the drive in a specific way

C:\Username\MyDir becomes /c/Username/MyDir

Hopes it helps.
If not please provide more info.


1 Like

my issue is related to the 2nd video of the GIT titled “Initializing a Repository”

After having configured the GIT, Mosh has ~Projects/Moon in his BASH Command, so I cannot set my folder to have .git in, but when I hit “git init” by default the folder is automaticly goes to C drive, but I want it the D drive. So i cannot change the root folder.
I`ve tried your advice, but here’s what I get below:
(1st action)
$ /d/coding/Progetti
bash: /d/coding/Progetti: Is a directory

(2nd action)
$ git init
Reinitialized existing Git repository in C:/Users/Orazbek/.git/

Unfortunately i can’t set my folder to store eventual .git documents etc…

Use the cd command to change the directory:
cd /d/coding/Progetti

1 Like

thank you !! now i’ve changed the root folder, another issue now i can’t open .git even if i’ve initiated and have .git in my folder

$ open .git
bash: open: command not found

You are on a Windows machine. So try explorer or start instead of open.

1 Like

i higly appreciate it, i tried with “start” and it works on Windows.