Install the pipenv but still get a command not found error

I installed the pipenv.

➜ YelpAPI pipenv install requests
zsh: command not found: pipenv
➜ YelpAPI pip3 list
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see ImportError in system pip wrappers after an upgrade · Issue #5599 · pypa/pip · GitHub for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with ‘-m pip’ instead of running pip directly.
Package Version

appdirs 1.4.4
astroid 2.4.2
autopep8 1.5.4
certifi 2020.12.5
chardet 4.0.0
distlib 0.3.1
filelock 3.0.12
idna 2.10
isort 5.7.0
lazy-object-proxy 1.4.3
mccabe 0.6.1
pip 21.0
pipenv 2020.11.15
pycodestyle 2.6.0
pylint 2.6.0
setuptools 41.2.0
six 1.15.0
toml 0.10.2
urllib3 1.26.3
wheel 0.33.1
wrapt 1.12.1
virtualenv 20.4.2
virtualenv-clone 0.5.4

I still get an error when I try to use pipenv → zsh: command not found: pipenv

If you’re on windows, check to see if the python folder is added to path. Or the path may be incorrectly added. Fixing that should solve this error

I’m on Mac. Could you help me about checking if python folder is added to the path on Mac?