Auto complete of videos does not work anymore

Hi there. Since yesterday I experienced that the videos in the course are not marked as completed after viewing them. Until yesterday, the video was marked correctly and the preview of the next chapter was shown immediately. I have tried it on my mac, both with Safari and Firefox but the behaviour is also the same on the iphone with safari.

It seems to me that something has changed here. Does anybody experiences the same?

Edit: Of course, I have the “Autocomplete” and “Autoplay” settings activated :slight_smile:

BR Ben

4 Likes

I’m having a similar issue. I noticed that the video player has changed, the new one does look good, however, autocomplete and autoplay do not work, which is a bit uncomfortable as I now have to click each time I play a video.

@programmingwithmosh could this be something that’s wrong with the new video player, or are we doing something wrong? here’s a link to the Jam recording and report Jam, you should find all the info needed about OS and Browser :slight_smile:

Many thanks,
Owsama

1 Like

I am having this issue as well, also I have to unmute for every video. Is there any way to roll back what you had and fix this in the backend before rolling it out? This makes using your site almost unbearable. If I go through 20 modules, I have to: Hit “Complete and Continue” button after each finishes. This moves it to the next module which starts with the sound off, so I have to hit the button to unmute.

Please roll back, or have the option to use the old player.

3 Likes

Huge :+1: to this thread.

It looks like at least a few of the video features are no longer working correctly:

  1. Autocomplete does not work at all (even after hard reload of the page)
  2. Autoplay triggers the videos to play muted

Also, since no one else has already seconded it, I just wanted to verify that my videos are also playing muted on start with Autoplay. I think this happens if you have Autoplay enabled and click on the “Complete and Continue” just as @robsaye described. With Autoplay disabled, I just have to click play manually, but then it does not start out muted.

This whole thing seems like there is some strange mismatched wiring going on here that has broken the student video experience.

2 Likes

@programmingwithmosh - just updating that it looks like the Autocomplete function is working again, but when I enable Autoplay my videos still start out muted. So it looks like issue 1 is resolved, but issue 2 is still ongoing.

1 Like

That is still an issue for me and it is driving me crazy :sweat_smile:

2 Likes

@programmingwithmosh @codewithmosh this is still ongoing and yet-another user has reported the same here.

For the record, I am not sure when it started working again, but I turned Autoplay back on today to test if it is still an issue and the second issue (“Autoplay triggers the videos to play muted”) appears to be gone. So now everything appears to be working correctly (Autoplay and Autocomplete). Thanks!