Unpacking Arrays C++

In part two of the C++ course in the arrays section it talks about unpacking arrays. I am getting an error saying x idenfier undefined. I have searched online how to do this using the auto keyword and what i come up with is not whats in this video.

// Codewithmosh.cpp : This file contains the 'main' function. Program execution begins and ends there.

#include <iostream>

using namespace std;

int main()
	int values[3] = { 10, 20, 30 };

	auto [x, y, z] = values;

// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
// Debug program: F5 or Debug > Start Debugging menu

// Tips for Getting Started: 
//   1. Use the Solution Explorer window to add/manage files
//   2. Use the Team Explorer window to connect to source control
//   3. Use the Output window to see build output and other messages
//   4. Use the Error List window to view errors
//   5. Go to Project > Add New Item to create new code files, or Project > Add Existing Item to add existing code files to the project
//   6. In the future, to open this project again, go to File > Open > Project and select the .sln file

1 Like

You do not have a type set for variables x y and z defined. You need at least

char x =0;


int x = 0; for all three. The system does not know what type x is, that is why the error.

I am having the same error. Setting the type for x, y, z does not fix the issue either.

So fix the issue, you have to go in your visual studio and update the C++ language standard to C++17 or later.

In Visual Studio, you can add the /std:c++17 flag to your project properties by following these steps:

  1. Right-click on your project in the Solution Explorer and select “Properties”
  2. Navigate to “C/C++” → “Language”
  3. Change the “C++ Language Standard” to “ISO C++17 Standard (/std:c++17)”

it will take away the error.


Intializing all of them did not fix the error.

This worked for me,

Thank you @Rubayat26 !

I still can’t figure this out! What might be the problem?