Mastering React.JS setup backend server prob?

I got problem with setting up the backend when i enter "npm i " i got this error and node-modules insist to be downloaded

anyone can help !!!

Please share the error message that is shown when you run npm i.


npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\HP\AppData\Local\npm-cache_logs\2022-04-10T21_22_05_552Z-debug.log

Can you post the contents of the file C:\Users\HP\AppData\Local\npm-cache_logs\2022-04-10T21_22_05_552Z-debug.log or upload it to Dropbox or somewhere?

1 Like

Please follow the answer in this stackoverflow thread: node.js - node-pre-gyp ERR! Tried to download(404) while migration in windows 10 - Stack Overflow

1 Like

Thanks u so much for your help I found the solution according to your help thanks
this link can help others (gulp - How to solve npm install error “npm ERR! code 1” - Stack Overflow)

Did you downgrade the node version? To which version?

1 Like

No i didn’t i deleted bcrypt old version from package-lock.json then run “npm i” and reinstall bcrypt using “npm i bcrypt --force” and it’s worked

1 Like

Hi guys, I had the same issue as OP. I ran the script from what was suggested in the Stackoverflow. But powershell seems to be stuck (running with Admin priv). Has anyone experience this, while running in windows

1 Like

Pls share your error i know this step will stop here and nothing will work so pls try it in VS code and share the error content

Here’s the link to google docs

This is what appear in VS ? after running npm i ?

Yes this is when I ‘npm install’ on the terminal in VS Code.

Then I followed what was suggested by sufian.babri

run ‘npm install --global --production windows-build-tools’ but then Powershell seems to hang up and posted the log above.

Try run “npm clean cache --force” and then “npm i --force”

Didn’t work.

Error log below.

1 Like

Okay delete bcrypt version from package-lock.json dependencies and run "npm i "

left the version as blank like this, and run npm i = same error
then deleted the entire dependency of ‘bcrypt’ and run npm i but still same error

“bcrypt”: {

  "version": "",

  "resolved": "",

  "integrity": "sha512-pRyDdo73C8Nim3jwFJ7DWe3TZCgwDfWZ6nHS5LSdU77kWbj1frruvdndP02AOavtD4y8v6Fp2dolbHgp4SDrfg==",

  "requires": {

    "nan": "2.6.2",

    "node-pre-gyp": "0.6.36"


1 Like

I’m sorry for mistake just delete it from Package.json and run "npm i "

that worked!. but does this lesson need the ‘bcrypt’ dependency?
Have you completed the entire course?

1 Like