Is the docker course outdated?

Hi,
Is the docker course outdated?

I’m curious as well, specifically the “Deploying applications” section. Everything up to that still seemed to be relevant and useful.

I’m having trouble installing docker-machine, it seems to be depreciated. I wonder if containers are still deployed this way

1 Like

As the docker technology is not well introduced in the companies yet and people are not well known with the docker technology. So we cant say that this is outdated.

i ran into this as well. looks like you don’t need docker-machine though if you use the --context configuration in your docker-compose commands.

once you create a new context (for the remote host) you can just use the docker and docker-compose commands from your local computer but it will apply commands to remote host.

this was a great guide for walking through the steps:

2 Likes

https://github.com/docker/machine
has been archived since 2018.
I’m happy that I figured this out before committing myself too deeply to the Deploying Applications section.
@mosh, you should at least include a note at the beginning of the section about this, and at least suggest new, alternative approaches, before letting students dive deep (with their valuable time!) into a deprecated technology.

I see what you mean about the last section. I stumbled upon this thread when having trouble with an earlier section (running multi container apps). I was trying to build the containers but not seeing them in the docker desktop or finishing the build with MongoDB.

the reference above helped me learn how to deploy correctly, because it included in the steps the needed extra flag to make sure the context was right (-d) when I executed docker-compose up -d. I think it’s important to also update the yml file to the latest version of docker you are using. (correction – while watching the videos I see Mosh put -d in and I missed it. Just FYI for someone who happens upon this thread thinking they weren’t at fault :wink: )

**final edit: I reviewed the videos about building the app in docker and had an issue with docker-compose build but using docker-compose up -d worked fine. I didn’t watch the entire video again to make sure this was right 100% but I think if you had the issue I had (build failed) then this may help… good luck

thanks guys for all these replies and help!