Database is not working

Hi, guys. What is the problem for it after I open the create-databases file? Only the sql_invoicing is successful produced. Any solution for it?

Hi everyone, I also ran into the same issue. Any help would be appreciated. Thanks

The error message is saying

Unknown collation: 'utf8mb4_0900_ai_ci'

So maybe you’ll need to try a different collation? According to this issue, folks have fixed this by using




So in your create-databases script, find all of the utf8mb4_0900_ai_ci and replace them with utf8mb4_unicode_ci

According to the manual

utf8mb4_0900_ai_ci is implemented only as of MySQL 8.0, so the 5.7 server does not recognize it.

And looks like you’re using MySql 5.7, so that explains it right?

And according to this SO post, utf8_unicode_ci is the one to use instead.

By the way, a collation is the set of rules which describes how to sort and compare textual data. For example, these are the rules your database engine is following when it decides that apple comes before banana.

Hi, it’s worked!!! Thank you so much.

Yes, you are right, i am using the 5.7 server. Thank you so much!! My problem is fixed!!

I have the same issue and i new to programming , I need help to progress on this

Where are you getting stuck? Have you tried replacing utf8mb4_0900_ai_ci with utf8mb4_unicode_ci?