All rows not showing in SQL table output display

In my SQL database, I have a table with 16000 rows. But when I open that table in SQL it is showing only 1001 rows in the output display. But SELECT COUNT(*) is returning 16000.
Any reason why the remaining rows are not displaying by default in the output display?


Isn’t there are feature that limits the number of rows it displays by default ?

You state 1001 rows which reminds me SSMS has an option to select the 1000 first rows.

The reason for that is to avoid returning too many rows uselessly.

IMHO 1000 is already too much.

Then, be sure to do a proper SELECT without any TOP or LIMIT clause.

1 Like

MySQL Workbench has that, too and it’s on by default. @Nav you can turn off that limit in Edit/Preferences, SQL Editor, SQL Execution, Select Query Results, Limit Rows.

1 Like

Thanks…this helped in understanding the reson