Cannot install dependencies for vidfly-api-node

I’m currently taking the mastering react course, in have a problem in installing the dependencies for vidfly-api-node. Apparently there are some 404 errors when getting modules and trying to compile using node-gyp.
When i ran: npm i
I got the message below

Tried to download(404):
node-pre-gyp ERR! Pre-built binaries not found for bcrypt@1.0.3 and node@12.13.1 (node-v72 ABI) (falling back to source compile with node-gyp)
How can i solve this??

Hi, use bcrypt newest version is also worked. So detele the package-lock.json and node-modules and run npm i again.

If it is still not worked, install the package seperately, npm i bcrypt.

If this still not worked, delete package-lock and node-modules, run yarn install instead.


I had the same issue. During Node Setup “bcrypt” couldn’t be installed.

The easy solution is just switch from the “bcrypt” npm module to bcrypt-nodejs. It’s the exact same API, but pure JS so no native add-ons to deal with.

npm uninstall --save bcrypt
npm install --save bcrypt-nodejs

Modify “const bcrypt = require(‘bcrypt-nodejs’)” in users.js and auth.js files.



Hi all.
I had the same issue; hakuhal’s solution did not work out for me, but suhrobmuboraksho’s solution did.

Additionally, i just encountered a server issue where i couldn’t post new users. The solution i found was to replace the calls to bcrypt.genSalt(10) by bycrypt.genSaltSync(10), and bcrypt.hash(user.password, salt) by bcrypt.hashSync(user.password, salt).

The original methods have been updated and now need to be provided a callback function in parameters, but those works just as the old ones.

Edit: Also compare with compareSync

Update: “bcrypt-nodejs” is deprecated. install “bcryptjs” instead. I encountered a problem when started Section 8 (Calling Backend Services). I was not able to register user. After some research “bcryptjs” was the solution.

1 Like

thank youuu suhrobmuboraksho

may i know the explanation behind this ?

Thank you so much for your solution…


I am still facing issue in getting the users in my mongodb.

bcryptjs worked also for me. Thanks suhrobmuboraksho

Hey guys. i had the same issue but after following the thread i solved it. Thank you so much. However in my database collection i am missing the users. does anyone know how to solve this ?

I had the same error and i solve it thanks to you